Î ïðîãðàììå

О программе

 Top Next

Драйвер ИБП (UPS) Windows XP/Vista

Драйвер распространяется бесплатно. Автор не несет ответственность за любой ущерб (особый, случайный, косвенный или опосредованный) или убытки (включая, но не ограничиваясь только перечисленным, упущенную выгоду, убытки, вызванные утратой конфиденциальной или иной информации, перерывами в коммерческой или производственной деятельности, нанесением ущерба здоровью, нарушением неприкосновенности частной жизни, неисполнением любого обязательства, включая обязательство действовать добросовестно и с разумной осмотрительностью, убытки, вызванные небрежностью, любой иной ущерб и прочие убытки имущественного или иного характера), возникающие в связи с использованием или невозможностью использования драйвера.

Данный драйвер нацелен на определенную целевую аудиторию, если он, Вас, чем-то не устраивает, значит Вы к ней не относитесь. Тогда, используйте стандартное ПО для ИБП для Ippon, сайт www.ippon.ru или любое другое, например www.ibakh.narod.ru

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Âîçìîæíîñòè ïðîãðàììû

Возможности программы

 Top Previous Next

Возможности драйвера:

Общие:

- поддержка ИБП производства Ippon/Mustek и возможно других использующих Megatec Protocol UPS

- подключение к ИБП по RS232/USB

- работа в OC Vista/WXP

- платформа x86/x64

- работа в режиме служба [+ интерфейс]

- сбор статистики

Возможности службы:

- выключение компьютера при сбое в питании: через определенное время после сбоя, по разряду батареи

- выключение компьютера в двух режимах: выключение / спящий режим

- выключение ИБП после выключения комьютера: после сбоя, после ручного выключения

- включение ИБП, после выключения при сбое

- поддержка WMI счетчиков производительности

- ведение статистики

Возможности UI

- отображение информации о ИБП, через уведомительное сообщение

- полное отражение состояния ИБП в реальном времени

- поддержка Fast User Switching & Remote Desktop

- установка параметров для обеспечения всех возможностей службы

- вкл/выкл сигнала ИБП, и так же в заданый период времени

- переопределение значков состояния ИБП в информационной области панели задач

- просмотр статистики: по годам/по месяцам/по дням/по секундам


×àñòî Çàäàâàåìûå Âîïðîñû

Часто Задаваемые Вопросы

1. Что делать, если меня не устраивают значения Umin, Umax? У меня они совсем другие и батарея у меня другая.

Значения Umin, Umax для выбранной модели ИБП можно поменять в реестре в ветке

SYSTEM\CurrentControlSet\Services\UPS\db

находим свою модель и меняем

2. Ёмкость батареи неправильно показывается, при правильно выбранной модели (кроме Other)

Значит у Вас, стоит другая батарея, для нее необходимо найти напряжение при полном заряде и разряде, потом изменить значения UMIN, UMAX в реестре

для данной модели. например, у Вас, выбрана модель Back Power Pro 800, а значение емкости показывается не правильно. Батарея полностью заряжена.

Выставляем в свойствах "Время работы от батареи" больше 100 мин. Выдергиваем кабель питающий ИБП,

и снимаем среднее значение напряжения на батарее, например: 13 (В), потом ждем, когда ИБП отключится сам,

периодически снимая напряжение на батарее, после отключения берем последнее значение, например: 10.4 (В)

меняем строчки в реестре (SYSTEM\CurrentControlSet\Services\UPS\db)

для Back Power Pro 800

с:

UMIN:21.1

UMAX:24.5

на:

UMIN:10.4

UMAX:13.0

(при таком эксперименте, все несохраненные данные на компьютере будут утеряны, делайте это на свой страх и риск,

если есть индикаторы разряда батареи, можно подождать, когда они будут показывать 50%, берем текущее напряжение U, получаем Umin = Umax - 2*(Umax-U))

3. Моего ИБП нет в списке, и вообще он не поддерживается. Но при выборе ИБП "Ippon/Other" все работает, как добавить мой ИБП?

В реестр добавить:

[SYSTEM\CurrentControlSet\Services\UPS\ServiceProviders\Vendor]

"Model"="0x0f;Path\ippon_dll.dll"

где :

Vendor - имя производителя

Model - название модели

Path - путь

например:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\UPS\ServiceProviders\Ippon]

"Back Power Pro 400"="0x0f;c:\\ups\\ippon_dll.dll"

далее в ветку:

[SYSTEM\CurrentControlSet\Services\UPS\db]

записать

"Model"="данные"

где данные (REG_MULTI_SZ) - VA, нижний порог напряжения на батарее, верхний и время работы при различной нагрузки,

при одинаковых VA и батарее, данные можно скопировать с друго ИБП

4. Закрыл UI интерфейс, что будет с ИБП?, как его вернуть?

С ИБП ничего не будет, UI интерфейс на его работу никак не влияет, как и на работу данного драйвера.

При следующем входе в систему он вернется.

Если очень нужно, то можно запустить ippon_ups.exe /gui

HINT: Так можно запустить UI, когда он отключен

5. Как перевыбрать модель ИБП?

Запустить ippon_ups.exe /setup

6. Почему после входа в ждущий режим (Suspend) ИБП выключается?

Windows не разделяет уведомительные сообщения на выключение/сброс и ждущий/спящий режим. Поэтому используйте опцию: Выключить ИБП при выкл. PC, очень аккуратно. При перезагрузки риск выключения ИБП, меньше, так как при старте службы, она деактивирует выключение ИБП. Старайтесь не использовать режимы Reset/Suspend или используйте встроенный механизм работы с питанием в UI.

7. Под какими Windows тестировалась программа?

Windows 2000 Pro SP1 (5.0.2195)

Windows XP x86 Pro SP2 (5.1.2600)

Windows XP x64 Pro SP1 (5.2.3790)

Vista x86 Ultimate (6.0.6000)

Vista x64 Ultimate (6.0.6000)

8. Какие ключи существуют?

/install - инсталлировать

/uninstall - деинсталлировать

/setup - выбрать ИБП

/installGUI - включить автостарт UI

/uninstallGUI - выключить автостарт UI

/gui - запустить UI

/shutdownUPS - Выключить (Power OFF) + выкл. ИБП

/hibernateUPS - Спать (Hibernate) + выкл. ИБП

/shutdown - Выключить (Power OFF) + вкл. ИБП

/hibernate - Спать (Hibernate) + вкл. ИБП

/reset - Сброс (Reset)

/suspend - Ждать (Suspend)

9. Почему в Windows XP нельзя выбрать порт USB, а только COM?

При использовании USB, можно выбрать любой COM порт. Так как поиск в начале производится на USB, а потом на заданом COM порте

10. Как мне на новой версии ПО, переустановить WMI?

При повторной установки ПО, в расширенных настройках нажать два раза - Выкл/Вкл WMI

11. Какие USB ИБП поддерживаются?

Программа работает с ИБП поддерживающими протокол Megatec Protocol UPS и идентификаторами VID/PID:

VID_0665&PID_5161 - полная поддержка

VID_06DA&PID_0003 - полная поддержка

12. Почему во вкладке 'Тест' некоторые кнопки не работают?

Потому что ИБП не поддерживает полностью протокол Megatec

13. Че там за флажки в статистике?

UF - сбой в питании

BL - батарея разряжена

AVR - АВР вкл

BF - батарея нуждается в замене

SA - выключение активировано (обычно не работает на Ippon/Mustek/Sven)

SO - сигнал включен

T - тест вкл

14. Что включает в себя целевая аудитория?

Уровень: ИТ-специалист или выше

Потребность: чтобы выключался/засыпал компьютер при отключении света через N минут, и отключал ИБП

это служба + UI (XP/Vista)

хочу USB

никаких украшательств в UI, и чтобы ее вообще небыло видно

место в памяти и ресурсов много не жрал (никаких delphi подобных, язык C/C++)

когда делать нечего, посмотреть RAW данные с ИБП

когда делать совсем нечего, посмотреть статистику

Место: 1 топовый домашний компьютер + мой любимый большой профессиональный TFT монитор (а может и два)

15. У меня служба не стартует, что делать?

С версии v3.0 beta 1, программа перешла в статус FULL STABLE, поэтому она должна работать по любому. К этому моменту ее использует около 530 человек и ни у кого проблем не замечено. Поэтому скорее всего проблема кроется в Вашей ОС, которая повреждена, как выход нужно ее переустановить. Если Вы уверены,

что проблема не в ОС (стандартная программа для ИБП нормально работает с ИБП), тогда запустите программу dbgview, потом службу ИБП, снимите информацию с dbgview и отошлите ее разработчику.

PS. Прежде чем запускать службу проверьте:

- ИБП подключен к компьютеру через стандартные провода входящие в поставку к нему

- заданный порт (COM) не занят другой программой

- отключены стороние программы по работе с ИБП

16. Почему не реализован стандартный интерфейс связи ОС с батареями ACPI Battery?

В начале разработки рассматривались все варианты реализации взаимодейтсвия ИБП с ОС в том числе и с ACPI Battery

все за и против:

- повышенные требования к информации с ИБП (требуется множество данных, которые ИБП Ippon/Mustek не могут предоставить)

- повышение сложности реализации и отладки (так как интерфейс является драйвером низкого уровня)

- при ошибках реализации выпадание сразу в синий экран (BSOD)

+ ОС знает о батарее

Основной не реализации этого интерфейса явилось, разность концепций. Так как он расчитан на работу от батарей длительное время с последующем управлением устройствами с целью сбережения ресурса батарей. Концепция работы часами (используется в ноутбуках). Для ИБП ситуация обратная, он должен дать возможность безопастно выключить компьютер. Концепция работы несколько минут. Как видно, концепции разошлись, для первой концепции нужно большая емкость батарей и дополнительная информация для эффективной работы (токи и т.д.), ни того ни другого, ИБП Ippon/Mustek дать не могут (так как класс совсем другой)

17. Почему при выключении ОС через ПО, система падает в BSOD?

Драйвер ИБП не является драйверов низкого уровня, если сказать точнее это служба, она как и любое приложение не может вогнать систему в BSOD,

максимум, что она может это упасть, как любое приложение (Программа выполнила недопустимую операцию и будет закрыта). Скорее всего при выключении

компьютера подвисает один из драйверов (видео, звук, тюнер, и т.д.), обновите драйвера.


Òåõíè÷åñêàÿ ïîääåðæêà

Техническая поддержка

Техническая поддержка осуществляется автором. Если у вас возникли проблемы, вопросы или пожелания, Вы можете связаться с ним по электронной почте или написать ему личное сообщение на форуме


Àâòîð

Автор

 Top Previous

Алексей Ильин

Город Тула

Российская Федерация

AlexeyIlyin@yandex.ru

This help file was created with an unregistered evaluation copy of Help & Manual. © EC Software. All rights reserved. This message will not appear if you compile this help file with the registered version of Help & Manual.


Èñòîðèÿ âåðñèé

История версий

v3.0 beta 3

- добавлено альтернативное уведомление (расширенные настройки)

- добавлен ИБП Mustek PowerMust 2000 USB

v3.0 beta 2

- выключение компьютера с командной строки

- в статистики во вкладке По дням, за место пустых дней показывается общее время работы

- блокировка выключения ИБП из UI

- блокировка выключения при сбое

- звуковое оповещение при: нестарте службы, выключении ИБП, отказе UI, при отложеном действии

- возможность отложить действие на N секунд

- теперь меню питание доступно не под администратором

- теперь всплывает потерянное окно с настройками по клику на трее

v3.0 beta 1 (FULL STABLE)

- VISTA ready

- статистика

- поддержка платформы x64

- поддержка Fast User Switching & Remote Desktop

- полное разделение службы и UI

- поддержка UI разрешения до 125 DPI

- поддержка выключения ИПБ, при ручном выключении компьютера

- включение ИБП через определенное время, после выключения при сбое

- возможность задавать значек состояния ИБП в информационной области панели задач (расширенные настройки)

- добавлено выключение ПК по напряжению батареи

- в лог пишутся новые события: вкл/выкл AVR, выключение по емкости и напряжению, выход из ручного спящего режима

- уведомления о работе от батареи по индикаторам клавиатуры

- возможность активации выключения/сброса и спящего/ждущего режима через UI

- теперь только у администратора доступна вкладка настройки

- исправлено не исчезновение контекстного меню

- вкладка тестирования ИБП (расширенные настройки)

- работа с USB под Win2k

- полная поддержка ИБП USB VID:06DA PID:0003

Известные проблемы в версии v3.0 beta xxx

Под VISTA:

- Не работают WMI счетчики

- Перестает всплывыть баллон с информацией о ИБП (при включении гаджетов)

- UAC должен быть отключен

v2.7.5

- теперь работает счетчик Bat

v2.7.4

- исправлена ошибка исчезновения вкладки настройки в Windows 2000

v2.7.3

- исправлена критическая ошибка (проявляется не стартом службы, очень редкая, баг с версии v1.0)

рекомендовано - обновление!

- исправлено выключение ИБП Sven

- добавлен значек состояния AVR в информационной области панели задач

- добавлен ИБП Mustek PowerMust 1400 USB

- поддержка WMI счетчиков производительности, включается только вручную в расширенных настройках

- WMI объект переименован с UPSperf в UPS

- добавлена возможность включить сигнал ИБП в определенный период времени

- набор счетчиков WMI увеличен

v2.7.2

- исправлены значения Umin, Umax в базе данных для ИБП Smart Winner 750, Back Power Pro XXX

v2.7.1 alpha, WMI edition

- поддержка WMI счетчиков производительности

- теперь работает разделяемая память (баг с версии v1.0, так его никто и не нашел, значит она никому была и не нужна :( но тепер WMI использует ее)

- возможность вкл/выкл сигнала ИБП перенесена в расширенные настройки, теперь уведомления работают как в старые добрые времена

- добавлен ИБП Smart Winner 750

v2.7

- добавлено выключение ПК по разряду батареи (используйте только при откалиброванной батарее)

- добавлен ИБП Mustek PowerMust 1000 USB

v2.6

- отображается время прошедшее после сбоя, через уведомительное сообщение

- отображается температура (опционально), через уведомительное сообщение

- переработан формат хранения базы данных о ИБП, теперь можно устанавливать любое значение нагрузки для времени работы

(используется для расчета оставшегося времени работы от батареи)

- добавлены ИБП Smart Winner 1500/2000/3000

v2.5

- проект переведен на VS2005

- поддерживается USB ИБП VID:06DA PID:0003

- улучшено восстановление работ ИБП на USB, при сбоях на USB

- улучшено определение ИБП на последовательном порте при старте службы

- теперь ИБП на USB используется монопольно

- добавлен ИБП Sven Power Pro+ 700

v2.4

- отображается дополнительная информации о ИБП, через уведомительное сообщение

- возможность вкл/выкл сигнала ИБП

v2.3

- теперь поддерживается ИБП производства Mustek:

Mustek PowerMust 400 USB

Mustek PowerMust 600 USB

Mustek PowerMust 800 USB

хорошо когда производители не изобретают велосипед, а используют один и тот же протокол: Megatec Protocol UPS

v2.2

- теперь компьютер не уходит в спящий режим при следующей загрузке,

если перед этим во время перебоя питания, компьютер был переведен

в спящий режим принудительно пользователем

- отображается напряжение на батарее, через уведомительное сообщение

- теперь отображается приблизительное время работы батареи, если нагрузка меньше 125 VA

- исправлено не отображение значения нагрузки "VA", если нагрузка меньше 125 VA

- теперь данные о ИБП берутся из реестра для выбранной модели

данные о модели включают в себя: VA, нижний порог напряжения на батарее, верхний и время работы при нагрузке

(по умолчанию, данные о нагрузке были взяты с рекламы на коробке для Ippon, а для значения 0VA проэкстраполированы :)))

v2.1

- восстановление работы ИБП через USB после выхода из спящего режима

v2.0

- поддержка канала связи через USB

- отображение дополнительной информации о ИБП, через уведомительное сообщение

- отображение основных состояний ИБП, через значок в информационной области панели задач

- поддержка выключения ИБП, после завершения работы (отводится 3 мин)

v1.0

- поддержка канала связи через последовательный порт RS232